mwbr.net
当前位置:首页 >> jDk1.8不兼容tomCAt7吗? >>

jDk1.8不兼容tomCAt7吗?

不呀,我就是jdk1.8,tomcat7,

支持,看看你的类是不是在1.7的java环境编译的,还有看看你的tomcat使用的jre是不是1.8的,是不是装了多个不同版本的jre,可能是tomcat引入的jre和jdk的不一样

你说反了,而应该问jdk1.8支持tomcat7吗?tomcat底层运行的就是java的Socket,也就是说tomcat是在jdk环境下运行的。而且这也不是问题,tomcat本来就是用java语言写的,java版本高1.8肯定支持tomcat7了,好像tomcat7在某个版本(7.0.72,具体记不...

支持"、、、

比如tomcat7,对应的jdk就是1.7。tomcat8,对应的就是jdk1.8 依次类推支持的

你先试试就这么部署一下,如果是因为jdk的问题无法访问那就没辙了,1.8可能向下不兼容

可以,在系统环境变量里面配置就可以了,你可以百度搜索(jdk配置)和(tomcat配置)有图文详解,都是对的,我看了。所以我就简略这部分回答了。毕竟手机回答有限。

url路径去掉WebRoot. http://127.0.0.1:8080/text1/find_stu.jsp

从官方版本说明来看,jdk1.8跟Tomcat 7应该是兼容的,如图: 原链接:http://tomcat.apache.org/whichversion.html

支持,看看你的类是不是在1.7的java环境编译的, 还有看看你的tomcat使用的jre是不是1.8的, 是不是装了多个不同版本的jre, 可能是tomcat引入的jre和jdk的不一样

网站首页 | 网站地图
All rights reserved Powered by www.mwbr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com